Cell Tower Search


I’m trying to search for towers using the required parameters (MCC, MNC, LAC, Cell ID) and nothing happens when I click on the ‘search’ button. I’ve tried on my phone and on my laptop and nothing happens after clicking ‘search’ each time. Does this mean the towers don’t exist in the database yet or is there some other issue I’m not aware of? Thanks for any help you can provide.

Hi Verity, where exactly are you doing the search?

Hi MobileM,

I’m searching the OpenCelliD database both on my android phone in an app and on my Windows laptop in a browser window. Thanks.

Hi Verity, Which specific app, and which url / website?

The app is Cell Spy Catcher. The url is https://opencellid.org/. Thanks.

Hi Verity,

Using the search function in the map at https://opencellid.org/ , search appears to be working properly for me, though it may not always be obvious.

If there is a cell matching the criteria, the map simply centres the cell, with no further highlighting. If map does not move, either the cell is already centred, or does not yet exist on the map.

You can test to see the behaviour of the map by using search criteria for a cell that you know to be on the map (e.g. MCC 311, MNC 480, LAC 20225, CID 20336641). Move map to somewhere over Europe or South America. Then search for cell mentioned above. You should see map centre over the cell, but no other indication beyond that.

Not sure about the Cell Spy Catcher app as I have yet to try that.

If you would like, you can provide the search criteria of an example of a cell you are trying to find but cannot, and I can try searching for it to see if map is finding it?

Thanks for your reply. I tried the search of https://opencellid.org using the criteria you provided and it worked. I think I had been entering the MCC and MNC data incorrectly. I was using 6 digits, which is both of them combined. When I enter them as 3 digits separately the search worked and I found the cell towers on the map. Thanks again for your help.

Hi Verity,

Sure, no problem.